Skip to main content
CVE-2026-112816VulnerabilityPublished

Canonical LXD 4.0.14, 5.0.10, 5.21.8 · Improper Certificate Validation

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-112816· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 6.10.1 : patch LXD as a priority.

Data as of 30 Oct 2026, 20:19 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (canonical)CVSS 4.010.0
Patch
Available – fixed in 6.10.1, 5.21.9, 5.0.11 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade LXD and lxd to 6.10.1, 5.21.9, 5.0.11 or 4.0.15.

Affected software

ProductAffectedFixed in
LXDlxdAffected
  • >=6.9.0 <6.10.1
Fixed in
  • 6.10.1
LXDlxdAffected
  • >=5.21.8 <5.21.9
Fixed in
  • 5.21.9
LXDlxdAffected
  • >=5.0.10 <5.0.11
Fixed in
  • 5.0.11
LXDlxdAffected
  • >=4.0.14 <4.0.15
Fixed in
  • 4.0.15
GitHublxdpkg:github/lxdOther threatsAffected
  • >=4.0.14 <4.0.15
  • >=5.0.10 <5.0.11
  • >=5.21.8 <5.21.9
  • >=6.9.0 <6.10.1
Fixed in
  • 4.0.15
  • 5.0.11
  • 5.21.9
  • 6.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Canonical LXD versions 4.0.15, 5.0.11, 5.21.9, or 6.10.1 or later. No other mitigations are indicated. Patch status is confirmed by the presence of fixed versions.

Description

An improper certificate validation vulnerability exists in the HTTPS listener of Canonical LXD versions 4.0.14, 5.0.10, 5.21.8, and 6.9. This flaw allows an unauthenticated attacker to impersonate any trusted client by using a crafted certificate chain, thereby gaining full access to the cluster and managed virtual machines. The issue is fixed in versions 4.0.15, 5.0.11, 5.21.9, and 6.10.1.

References

Community reviews

Loading reviews…