hackney_ssl · Improper Certificate Validation Vulnerability
Source GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.9.0 as a priority.
Data as of 26 Oct 2026, 16:37 UTC
- Patch
- Available – fixed in 4.9.0, 915eb5737e9c489d8fc22eec8cdae30e9b027be4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade hackney to 4.9.0; hackney to 915eb5737e9c489d8fc22eec8cdae30e9b027be4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| benoitchackney | Affected
| Fixed in
|
| hackneybenoitc/hackney | Affected
| Fixed in
|
Hexhackneypkg:hex/hackneyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should be cautious when relying on hackney_ssl for private CA pinning and consider additional validation controls or alternative libraries.
Description
An improper certificate validation vulnerability in hackney_ssl within the benoitc hackney HTTP client library allows an on-path attacker to impersonate a server pinned to a private certificate authority. The flaw arises because hackney_ssl's partial_chain callback trusts any certificate chain ending in a publicly trusted root, even when a private CA is pinned. Hostname verification still applies, so the attacker must have a publicly trusted certificate for the target hostname. This affects hackney versions from 1.24.0 up to but not including 4.9.0.
References
- nvd.nist.gov/vuln/detail/CVE-2026-115693 (opens in a new tab)
- github.com/benoitc/hackney/pull/978 (opens in a new tab)
- github.com/benoitc/hackney/commit/915eb5737e9c489d8fc22eec8cdae30e9b027be4 (opens in a new tab)
- github.com/benoitc/hackney/commit/d8a9afcf5c3849904274e2eba1df56c63d1a1a0c (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-115693.html (opens in a new tab)
- github.com/benoitc/hackney/releases/tag/4.9.0 (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-115693 (opens in a new tab)