CVE-2026-115693: benoitc hackney · Improper Certificate Validation
Affects benoitc hackneySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.9.0 as a priority.
Data as of 26 Oct 2026, 16:53 UTC
- Patch
- Available – fixed in 4.9.0, 915eb5737e9c489d8fc22eec8cdae30e9b027be4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade hackney to 4.9.0; hackney to 915eb5737e9c489d8fc22eec8cdae30e9b027be4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| benoitchackney | Affected
| Fixed in
|
| hackneybenoitc/hackney | Affected
| Fixed in
|
Hexhackneypkg:hex/hackneyOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:benoitc:hackney:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade hackney to version 4.9.0 or later, where this improper certificate validation vulnerability is fixed. No other mitigation is required as the fix addresses the root cause by correcting the trust anchor selection logic.
Description
CVE-2026-115693 is an improper certificate validation vulnerability in the hackney_ssl module of benoitc hackney. It allows an on-path attacker to impersonate a server pinned to a private certificate authority by exploiting the acceptance of certificate chains ending in a publicly trusted root. The hostname check remains enforced, requiring the attacker to have a publicly trusted certificate for the pinned hostname. This affects hackney versions from 1.24.0 up to but not including 4.9.0.
References
- github.com/benoitc/hackney/pull/978 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-115693.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-115693 (opens in a new tab)
- github.com/benoitc/hackney/releases/tag/4.9.0 (opens in a new tab)
- github.com/benoitc/hackney/commit/d8a9afcf5c3849904274e2eba1df56c63d1a1a0c (opens in a new tab)
- github.com/benoitc/hackney/commit/915eb5737e9c489d8fc22eec8cdae30e9b027be4 (opens in a new tab)