CVE-2026-111822: Apache ActiveMQ, Apache ActiveMQ · Improper Invalidation of Cached Authorizations Vulnerability
Source GCVE Database
Not known to be exploited : upgrade to 6.3.3 or 5.19.12 when convenient.
Data as of 4 Nov 2026, 16:28 UTC
Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 6.3.3, 5.19.12
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade Apache ActiveMQ and Apache ActiveMQ Runtime Config and org.apache.activemq/apache-activemq and org.apache.activemq/activemq-runtime-config to 6.3.3 or 5.19.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache ActiveMQorg.apache.activemq:apache-activemq | Affected
| Fixed in
|
| Apache ActiveMQorg.apache.activemq:apache-activemq | Affected
| Fixed in
|
| Apache ActiveMQ Runtime Configorg.apache.activemq:activemq-runtime-config | Affected
| Fixed in
|
| Apache ActiveMQ Runtime Configorg.apache.activemq:activemq-runtime-config | Affected
| Fixed in
|
Mavenorg.apache.activemq/apache-activemqpkg:maven/org.apache.activemq/apache-activemqOther threats | Affected
| Fixed in
|
Mavenorg.apache.activemq/activemq-runtime-configpkg:maven/org.apache.activemq/activemq-runtime-configOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache ActiveMQ and Apache ActiveMQ Runtime Config to versions 6.4.0, 6.3.3, or 5.19.12, where the issue is fixed. No other mitigation is indicated by the vendor advisory.
Description
A vulnerability in Apache ActiveMQ and Apache ActiveMQ Runtime Config allows improper invalidation of cached authorizations. Authenticated connections established before a principal's write grant removal can continue sending messages to the destination, bypassing new authorization restrictions. This affects versions from 6.0.0 before 6.3.3 and before 5.19.12. Upgrading to versions 6.4.0, 6.3.3, or 5.19.12 resolves the issue.