Skip to main content
VulnerabilityPublished

CVE-2026-111822: Apache ActiveMQ · Improper Invalidation of Cached Authorizations

Affects Apache ActiveMQSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 6.3.3 or 5.19.12 when convenient.

Data as of 4 Nov 2026, 12:28 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 6.3.3, 5.19.12

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Apache ActiveMQ and Apache ActiveMQ Runtime Config and org.apache.activemq/apache-activemq and org.apache.activemq/activemq-runtime-config to 6.3.3 or 5.19.12.

Affected software

ProductAffectedFixed in
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • <5.19.12
Fixed in
  • 5.19.12
Apache ActiveMQ Runtime Configorg.apache.activemq:activemq-runtime-configAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
Apache ActiveMQ Runtime Configorg.apache.activemq:activemq-runtime-configAffected
  • <5.19.12
Fixed in
  • 5.19.12
Mavenorg.apache.activemq/apache-activemqpkg:maven/org.apache.activemq/apache-activemqOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12
Mavenorg.apache.activemq/activemq-runtime-configpkg:maven/org.apache.activemq/activemq-runtime-configOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ and Apache ActiveMQ Runtime Config to versions 6.3.3, 5.19.12, or later, where this issue is fixed. No other mitigations are indicated by the vendor advisory.

Description

Improper invalidation of cached authorizations vulnerability in Apache ActiveMQ, Apache ActiveMQ Runtime Config. After the runtime configuration plugin removes a principal's write grant on a destination, an authenticated connection opened before the change can keep sending to that destination, including through a new anonymous producer, while fresh connections and new explicit producers are denied. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ Runtime Config: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

References

Community reviews

Loading reviews…