Skip to main content
VulnerabilityPublished

CVE-2026-108946: Apache ActiveMQ · Improper Input Validation

Affects Apache ActiveMQSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 6.3.3 or 5.19.12 soon.

Data as of 4 Nov 2026, 12:28 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 6.3.3, 5.19.12

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Apache ActiveMQ and ActiveMQ Broker and org.apache.activemq/apache-activemq and org.apache.activemq/activemq-broker to 6.3.3 or 5.19.12.

Affected software

ProductAffectedFixed in
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • <5.19.12
Fixed in
  • 5.19.12
ActiveMQ Brokerorg.apache.activemq:activemq-brokerAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
ActiveMQ Brokerorg.apache.activemq:activemq-brokerAffected
  • <5.19.12
Fixed in
  • 5.19.12
Mavenorg.apache.activemq/apache-activemqpkg:maven/org.apache.activemq/apache-activemqOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12
Mavenorg.apache.activemq/activemq-brokerpkg:maven/org.apache.activemq/activemq-brokerOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ and Apache ActiveMQ KahaDB to versions 6.3.3 or later, or 5.19.12 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.

Description

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. The ActiveMQ broker resolves connection, session and consumer state from ids that are user provided and in some scenarios does not validate that they ids are bound to that user. This allows an authenticated client to spoof another user's ids. This allows: *  an authenticated client consumes from another connection's temporary queue/topic by putting the victim's connection id in its own ConsumerId, bypassing the broker-side ownership check. * a duplicate ConsumerId registration is only logged, after which the attacker's RemoveInfo or disconnect tears down the victim's live subscription * a forged MessageAck for the victim's ConsumerId permanently deletes an in-flight, unacknowledged message. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3, or 5.19.12, which fixes the issue.

References

Community reviews

Loading reviews…