Skip to main content
VulnerabilityPublished

CVE-2026-111821: Apache ActiveMQ · Improper Input Validation

Affects Apache ActiveMQSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 6.3.3 or 5.19.12 soon.

Data as of 4 Nov 2026, 11:13 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 6.3.3, 5.19.12

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Apache ActiveMQ and Apache ActiveMQ KahaDB and org.apache.activemq/apache-activemq and org.apache.activemq/activemq-kahadb-store to 6.3.3 or 5.19.12.

Affected software

ProductAffectedFixed in
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
Apache ActiveMQorg.apache.activemq:apache-activemqAffected
  • <5.19.12
Fixed in
  • 5.19.12
Apache ActiveMQ KahaDBorg.apache.activemq:activemq-kahadb-storeAffected
  • >=6.0.0 <6.3.3
Fixed in
  • 6.3.3
Apache ActiveMQ KahaDBorg.apache.activemq:activemq-kahadb-storeAffected
  • <5.19.12
Fixed in
  • 5.19.12
Mavenorg.apache.activemq/apache-activemqpkg:maven/org.apache.activemq/apache-activemqOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12
Mavenorg.apache.activemq/activemq-kahadb-storepkg:maven/org.apache.activemq/activemq-kahadb-storeOther threatsAffected
  • >=6.0.0 <6.3.3
  • <5.19.12
Fixed in
  • 6.3.3
  • 5.19.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ to version 6.3.3, 5.19.12, or later, where this vulnerability is fixed. No other mitigation or workaround is indicated.

Description

CVE-2026-111821 is an improper input validation vulnerability in Apache ActiveMQ and its KahaDB storage. It allows a user to create a durable subscription with a clientId and subscription name whose combined length exceeds 65,535 characters, causing the broker to shut down and become unrecoverable. This affects Apache ActiveMQ versions from 6.0.0 up to but not including 6.3.3, and versions before 5.19.12. The issue is fixed in versions 6.3.3 and 5.19.12.

References

Community reviews

Loading reviews…