Skip to main content
VulnerabilityPublished

CVE-2026-109083: Apache Syncope · Improper Isolation or Compartmentalization Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-109083· High

Not known to be exploited · fixed in 4.0.9 : patch Apache Syncope soon.

Data as of 2 Nov 2026, 16:59 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 4.0.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Syncopeorg.apache.syncope.ext.flowable:syncope-ext-flowable-bpmnAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.8
  • >=4.1.0 <=4.1.3
Fixed in–
Mavenorg.apache.syncope.ext.flowable/syncope-ext-flowable-bpmnpkg:maven/org.apache.syncope.ext.flowable/syncope-ext-flowable-bpmnOther threatsAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.8
  • >=4.1.0 <=4.1.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Syncope versions 4.0.9 or 4.1.4, which fix the vulnerability by rejecting BPMN definitions that include expression attributes. Applying these updates prevents the unsafe execution of JUEL expressions within BPMN processes. No other mitigation is indicated.

Description

Apache Syncope versions 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.8, and 4.1.0 through 4.1.3 contain an improper isolation vulnerability. An administrator with sufficient entitlements can import BPMN process definitions via the REST API and start them. If the BPMN process includes a JUEL expression, it is executed directly on the server without sandboxing, potentially leading to unsafe execution of expressions. Versions 4.0.9 and 4.1.4 address this issue by rejecting BPMN definitions that include expression attributes.

References

Community reviews

Loading reviews…