Skip to main content
VulnerabilityPublished

CVE-2026-114526: Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-114526· High

Not known to be exploited : upgrade to 2.0.1 or 1.26.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.0.1, 1.26.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Black Hole to 2.0.1 or 1.26.0.

Affected software

ProductAffectedFixed in
DrupalBlack HoleAffected
  • >=2.0.0 <2.0.1
Fixed in
  • 2.0.1
DrupalBlack HoleAffected
  • <1.26.0
Fixed in
  • 1.26.0

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Black Hole allows Stored XSS. This issue affects Black Hole versions: from 0.0.0 to 1.26.0, from 2.0.0 to 2.0.1.

References

Community reviews

Loading reviews…