Skip to main content
VulnerabilityPublished

CVE-2026-114526: Drupal Black Hole · Cross-site Scripting

Affects Drupal Black HoleSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.0.1 or 1.26.0 soon.

Data as of 30 Oct 2026, 04:14 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.0.1, 1.26.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal Black Hole to 2.0.1 or 1.26.0.

Affected software

ProductAffectedFixed in
DrupalBlack HoleAffected
  • >=2.0.0 <2.0.1
Fixed in
  • 2.0.1
DrupalBlack HoleAffected
  • <1.26.0
Fixed in
  • 1.26.0

AI-suggested

Apply the official fixes by upgrading Drupal Black Hole to version 1.26.0 or later, or 2.0.1 or later. These versions address the stored XSS vulnerability. No additional mitigation steps are indicated.

Description

A stored cross-site scripting (XSS) vulnerability exists in the Drupal Black Hole module affecting versions from 0.0.0 up to but not including 1.26.0, and from 2.0.0 up to but not including 2.0.1. This vulnerability allows improper neutralization of input during web page generation, potentially enabling attackers to inject malicious scripts that are stored and executed in users' browsers.

References

Community reviews

Loading reviews…