Skip to main content
VulnerabilityPublished

CVE-2026-118576: Drupal Stage File Proxy · Cross-site Scripting

Affects Drupal Stage File ProxySource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 4.0.1 or 3.1.7 soon.

Data as of 30 Oct 2026, 03:45 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 4.0.1, 3.1.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal Stage File Proxy to 4.0.1 or 3.1.7.

Affected software

ProductAffectedFixed in
DrupalStage File ProxyAffected
  • >=4.0.0 <4.0.1
Fixed in
  • 4.0.1
DrupalStage File ProxyAffected
  • <3.1.7
Fixed in
  • 3.1.7

AI-suggested

Upgrade the Drupal Stage File Proxy module to version 3.1.7 or later, or 4.0.1 or later, where this vulnerability has been fixed. No other mitigation actions are specified.

Description

A Cross-site Scripting (XSS) vulnerability exists in the Drupal Stage File Proxy module. This flaw allows improper neutralization of input during web page generation, potentially enabling XSS attacks. The vulnerability affects Stage File Proxy versions from 0.0.0 up to but not including 3.1.7, and from 4.0.0 up to but not including 4.0.1. Fixed versions are 3.1.7 and 4.0.1.

References

Community reviews

Loading reviews…