Skip to main content
VulnerabilityPublished

CVE-2026-118560: Drupal Commerce Stripe · Cross-site Scripting

Affects Drupal Commerce StripeSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.2.3 soon.

Data as of 30 Oct 2026, 03:45 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.2.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal Commerce Stripe to 2.2.3.

Affected software

ProductAffectedFixed in
DrupalCommerce StripeAffected
  • >=2.0.0 <2.2.3
Fixed in
  • 2.2.3

AI-suggested

Upgrade affected Drupal Commerce Stripe installations to version 2.2.3 or later, where this vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.

Description

A Cross-site Scripting (XSS) vulnerability exists in Drupal Commerce Stripe versions 2.0.0 through 2.2.2. This flaw allows improper neutralization of input during web page generation, potentially enabling attackers to inject malicious scripts. The issue is fixed in version 2.2.3.

References

Community reviews

Loading reviews…