Skip to main content
CVE-2025-64318VulnerabilityPublished

Improper Neutralization of Input Used for LLM Prompting vulnerability in Salesforce Mulesoft Anypoint Code Builder allows Manipulating Writeable Configuration Files.This issue affects Mulesoft Anypoint Code Builder: before 1.11.6

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-64318· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.12.1 when convenient.

Data as of 4 Nov 2026, 17:16 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.12.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade mulesoft/anypoint-code-builder to 1.12.1.

Affected software

ProductAffectedFixed in
npmmulesoft/anypoint-code-builderpkg:npm/mulesoft/anypoint-code-builderOther threatsAffected
  • <1.12.1
Fixed in
  • 1.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Neutralization of Input Used for LLM Prompting vulnerability in Salesforce Mulesoft Anypoint Code Builder allows Manipulating Writeable Configuration Files.This issue affects Mulesoft Anypoint Code Builder: before 1.11.6.

References

Community reviews

Loading reviews…