Skip to main content
CVE-2024-31864VulnerabilityPublished Updated

Org.apache.zeppelin:zeppelin jdbc: Apache Zeppelin remote code execution by adding malicious JDBC connection string

Affects org.apache.zeppelin:zeppelin-jdbcSource GCVE Database

0
Compare
Authoritative record:CVE-2024-31864· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.11.1 as a priority.

Data as of 4 Nov 2026, 18:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
Patch
Available – fixed in 0.11.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.zeppelin:zeppelin-jdbc to 0.11.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.zeppelin:zeppelin-jdbcAffected
  • <0.11.1
Fixed in
  • 0.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Zeppelin to version 0.11.1 or later, where this vulnerability is fixed. No other mitigations are indicated or required by the vendor advisory.

Description

Apache Zeppelin versions prior to 0.11.1 contain a code injection vulnerability in the JDBC interpreter. An attacker can exploit this flaw by injecting malicious code or sensitive configuration through a crafted MySQL JDBC connection string. This vulnerability allows remote code execution without authentication. The issue is fixed in version 0.11.1.

References

Community reviews

Loading reviews…