Skip to main content
CVE-2024-31864VulnerabilityPublished Updated

CVE-2024-31864: Apache Zeppelin · Code Injection

Affects Apache ZeppelinSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.11.1 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade apache/zeppelin to 0.11.1.

Affected software

ProductAffectedFixed in
GitHubapache/zeppelinpkg:github/apache/zeppelinOther threatsAffected
  • <0.11.1
Fixed in
  • 0.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade all Apache Zeppelin instances to version 0.11.1 or later, which contains the patch for CVE-2024-31864. 2. Restrict JDBC connection permissions to the minimum necessary, ensuring that Zeppelin’s database user has limited privileges to reduce the impact of potential exploitation. 3. Implement network segmentation and firewall rules to limit access to Apache Zeppelin servers, allowing connections only from trusted sources. 4. Monitor logs for unusual or unauthorized JDBC connection attempts, especially those that could indicate injection attempts or anomalous queries. 5. Employ application-layer security controls such as Web Application Firewalls (WAFs) to detect and block suspicious payloads targeting the JDBC connection process. 6. Conduct regular security audits and code reviews of Zeppelin configurations and custom notebooks to identify and remediate insecure practices. 7. Educate administrators and developers on secure configuration and the risks of code injection vulnerabilities. 8. Consider deploying runtime application self-protection (RASP) tools to detect and prevent code injection attacks in real time. These measures, combined with prompt patching, will significantly reduce the risk posed by this vulnerability.

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

References

Community reviews

Loading reviews…