In Eclipse Mnestix Browser versions 1.6.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker
Source GCVE Database
Not known to be exploited · CVSS 9.2 Critical : upgrade to 2.3.0 as a priority.
Data as of 3 Nov 2026, 13:14 UTC
Thin evidence
One scorer or none| CNA (eclipse) | CVSS 4.0 | 9.2 |
|---|
- Patch
- Available – fixed in 2.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Eclipse Mnestix to 2.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse Mnestix | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to vulnerable versions and monitor for vendor updates.
Description
Eclipse Mnestix Browser versions from 1.6.0 up to but not including 2.3.0 contain a vulnerability that allows unauthenticated attackers to exfiltrate the MNESTIX_BACKEND_API_KEY for all configured Infrastructures. This vulnerability is identified as CVE-2026-89292 and has a critical severity rating with a CVSS score of 9.2.