Skip to main content
CVE-2026-123837VulnerabilityPublished

In JetBrains IntelliJ IDEA before 2026.3, 2026.2.1 command injection was possible in untrusted projects via Tomcat run

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123837· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 2026.3 soon.

Data as of 6 Nov 2026, 19:17 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.17.8
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • =0
Fixed in
  • 2026.3

AI-suggested

A fix is available in JetBrains IntelliJ IDEA versions 2026.3 and 2026.2.1. Users should upgrade to these versions or later to remediate this vulnerability. No additional mitigation steps are indicated in the provided data.

Description

A command injection vulnerability exists in JetBrains IntelliJ IDEA versions before 2026.3 and 2026.2.1 when using Tomcat run configurations on Windows Subsystem for Linux (WSL) in untrusted projects. This flaw could allow an attacker to execute arbitrary commands with the privileges of the affected process.

References

Community reviews

Loading reviews…