Skip to main content
CVE-2026-123311VulnerabilityPublished

In JetBrains IntelliJ IDEA before 2026.3, 2026.2.4 command execution via a hidden run control in the Markdown preview

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123311· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2026.3 when convenient.

Data as of 6 Nov 2026, 13:35 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.15.3
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade IntelliJ IDEA and com.jetbrains/intellij-idea to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • =0
Fixed in
  • 2026.3
Mavencom.jetbrains/intellij-ideapkg:maven/com.jetbrains/intellij-ideaOther threatsAffected
  • <2026.3
Fixed in
  • 2026.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with Markdown previews in affected versions and avoid opening untrusted Markdown content.

Description

A vulnerability in JetBrains IntelliJ IDEA before versions 2026.3 and 2026.2.4 allows command execution via a hidden run control in the Markdown preview feature. The flaw permits an attacker to execute commands with limited privileges, requiring local access and user interaction. The vulnerability has a medium severity rating with a CVSS score of 5.3.

References

Community reviews

Loading reviews…