In JetBrains IntelliJ IDEA before 2026.3, 2026.2.4 stored XSS was possible on the built-in web server via Markdown
Source GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 2026.3 when convenient.
Data as of 6 Nov 2026, 13:35 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 6.1 |
|---|
- Patch
- Available – fixed in 2026.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade IntelliJ IDEA to 2026.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
AI-suggested
Users should upgrade to IntelliJ IDEA version 2026.3 or 2026.2.4 or later once available, as these versions are indicated as fixed. Until then, avoid exposing the built-in web server to untrusted networks and be cautious with Markdown content from untrusted sources.
Description
A stored cross-site scripting (XSS) vulnerability exists in JetBrains IntelliJ IDEA versions before 2026.3 and 2026.2.4. The vulnerability occurs on the built-in web server through the Markdown preview feature, potentially allowing an attacker to inject malicious scripts that execute in the context of the affected application.