Skip to main content
VulnerabilityPublished

CVE-2026-123309: JetBrains IntelliJ IDEA · Cross-site Scripting

Affects JetBrains IntelliJ IDEASource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2026.3 when convenient.

Data as of 6 Nov 2026, 11:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.16.1
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade JetBrains IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • =0
Fixed in
  • 2026.3

AI-suggested

Upgrade IntelliJ IDEA to version 2026.3 or later, where this vulnerability is fixed. No additional mitigation steps are required as the vendor has provided an official fix.

Description

A stored cross-site scripting (XSS) vulnerability exists in JetBrains IntelliJ IDEA versions before 2026.3. The flaw is present in the built-in web server's Markdown preview feature, allowing malicious scripts to be stored and executed. This vulnerability has been assigned CVE-2026-123309 and is rated medium severity with a CVSS score of 6.1. The issue is fixed in version 2026.3.

References

Community reviews

Loading reviews…