Skip to main content
VulnerabilityPublished

CVE-2026-123301: JetBrains IntelliJ IDEA · Cross-site Scripting

Affects JetBrains IntelliJ IDEASource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 2026.3 soon.

Data as of 6 Nov 2026, 11:02 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.18.2
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade JetBrains IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.3
Fixed in
  • 2026.3

AI-suggested

Upgrade to JetBrains IntelliJ IDEA version 2026.3 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

A DOM-based Cross-site Scripting (XSS) vulnerability exists in JetBrains IntelliJ IDEA versions before 2026.3. The flaw occurs in the OpenAPI preview error view, allowing an attacker to execute arbitrary scripts in the context of the affected application. This vulnerability has been assigned CVE-2026-123301 and is rated high severity with a CVSS score of 8.2. The issue is fixed in version 2026.3.

References

Community reviews

Loading reviews…