Skip to main content
CVE-2026-123308VulnerabilityPublished

In JetBrains IntelliJ IDEA before 2026.3 code execution via the document import was possible in untrusted projects

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123308· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2026.3 when convenient.

Data as of 6 Nov 2026, 13:35 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.16.3
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.3
Fixed in
  • 2026.3

AI-suggested

Users should upgrade to version 2026.3 or later once it becomes available, as the vulnerability is fixed in that version. Until then, avoid importing documents in untrusted projects or restrict usage to trusted projects only. Monitor vendor advisories for official patches or updates.

Description

A vulnerability in JetBrains IntelliJ IDEA before version 2026.3 allows code execution via document import in untrusted projects. This flaw could enable an attacker to execute arbitrary code when importing documents in projects that are not trusted by the user.

References

Community reviews

Loading reviews…