Skip to main content
VulnerabilityPublished

CVE-2026-123308: JetBrains IntelliJ IDEA · Untrusted Functionality Inclusion

Affects JetBrains IntelliJ IDEASource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2026.3 when convenient.

Data as of 6 Nov 2026, 11:02 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.16.3
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade JetBrains IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.3
Fixed in
  • 2026.3

AI-suggested

Users should upgrade to JetBrains IntelliJ IDEA version 2026.3 or later, where this vulnerability has been fixed. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-123308 is a vulnerability in JetBrains IntelliJ IDEA before version 2026.3 that allows code execution via document import in untrusted projects. The flaw involves inclusion of functionality from an untrusted control sphere, classified under CWE-829. The vulnerability has a CVSS 3.1 score of 6.3, indicating a medium severity level. A fix is available in version 2026.3.

References

Community reviews

Loading reviews…