Skip to main content
VulnerabilityPublished

CVE-2026-123302: JetBrains IntelliJ IDEA · Untrusted Functionality Inclusion

Affects JetBrains IntelliJ IDEASource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 2026.3 soon.

Data as of 6 Nov 2026, 11:02 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.17.8
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade JetBrains IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • =0
Fixed in
  • 2026.3

AI-suggested

Users should upgrade to IntelliJ IDEA version 2026.3 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

CVE-2026-123302 is a high-severity vulnerability in JetBrains IntelliJ IDEA that allows code execution in untrusted projects via script engine discovery. This flaw affects versions prior to 2026.3, including 2026.2.4, 2026.1.5.1, and 2025.3.6.2. The vulnerability arises from the inclusion of functionality from an untrusted control sphere, categorized under CWE-829. A fix is available in version 2026.3.

References

Community reviews

Loading reviews…