CVE-2026-123313: JetBrains IntelliJ IDEA · Untrusted Functionality Inclusion
Affects JetBrains IntelliJ IDEASource CVE Database V5
Not known to be exploited · CVSS 3.3 Low : upgrade to 2026.3 when convenient.
Data as of 6 Nov 2026, 11:02 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 3.3 |
|---|
- Patch
- Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade JetBrains IntelliJ IDEA to 2026.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
AI-suggested
Upgrade to JetBrains IntelliJ IDEA version 2026.3 or later, where this vulnerability is fixed. No other mitigation is indicated or required by the vendor advisory.
Description
CVE-2026-123313 is a vulnerability in JetBrains IntelliJ IDEA before version 2026.3 where improper checks could allow disabled plugins to be enabled via external dependency settings. This flaw relates to the inclusion of functionality from an untrusted control sphere, classified under CWE-829. The issue has a low CVSS score of 3.3 and does not impact confidentiality or availability but can cause limited integrity issues. The vulnerability is fixed in version 2026.3.