Skip to main content
VulnerabilityPublished

CVE-2026-123301: In JetBrains IntelliJ IDEA before 2026.3 dOM-based XSS in the OpenAPI preview error view was possible

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123301· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 2026.3 soon.

Data as of 6 Nov 2026, 13:34 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.18.2
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.3
Fixed in
  • 2026.3

AI-suggested

A fix is available in JetBrains IntelliJ IDEA version 2026.3. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation guidance is provided in the available data.

Description

A DOM-based cross-site scripting (XSS) vulnerability exists in JetBrains IntelliJ IDEA versions before 2026.3 in the OpenAPI preview error view. This vulnerability could allow an attacker to execute arbitrary code in the context of the affected application. The flaw is identified as CVE-2026-123301 and has a high severity rating.

References

Community reviews

Loading reviews…