In JetBrains IntelliJ IDEA before 2026.3 untrusted projects could trigger changes to GPG agent configuration
Source GCVE Database
Not known to be exploited · CVSS 3.3 Low : upgrade to 2026.3 when convenient.
Data as of 6 Nov 2026, 19:17 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 3.3 |
|---|
- Patch
- Available – fixed in 2026.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade IntelliJ IDEA to 2026.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
AI-suggested
A fix is available in JetBrains IntelliJ IDEA version 2026.3. Users should upgrade to this version or later to remediate the vulnerability. No other mitigation details are provided.
Description
A vulnerability in JetBrains IntelliJ IDEA before version 2026.3 allows untrusted projects to trigger changes to the GPG agent configuration. This could potentially lead to integrity issues but does not impact confidentiality or availability.