Skip to main content
CVE-2026-118697VulnerabilityPublished

In JetBrains Toolbox App before 3.9.1 and 3.8.2; IntelliJ IDEA before 2026.3 and 2026.2.4, the jetbrainsd daemon

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118697· Critical 9.0

Not known to be exploited · CVSS 9.0 Critical : upgrade to 3.9.1 or 3.8.2 as a priority.

Data as of 30 Oct 2026, 20:03 UTC

CVSS 3.1 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.19.0
Patch
Available – fixed in 3.9.1, 3.8.2, 2026.2.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Toolbox App to 3.9.1 or 3.8.2; IntelliJ IDEA to 2026.2.4.

Affected software

ProductAffectedFixed in
JetBrainsToolbox AppAffected
  • >=3.9.0 <3.9.1
Fixed in
  • 3.9.1
JetBrainsToolbox AppAffected
  • <3.8.2
Fixed in
  • 3.8.2
JetBrainsIntelliJ IDEAAffected
  • <2026.2.4
Fixed in
  • 2026.2.4

AI-suggested

Users should upgrade JetBrains Toolbox App to version 3.9.1 or later and IntelliJ IDEA to version 2026.3 or 2026.2.4 or later, where this vulnerability is fixed. No other mitigation is indicated. Patch status is confirmed by the version boundaries given.

Description

A vulnerability exists in JetBrains Toolbox App versions before 3.9.1 and 3.8.2, and IntelliJ IDEA versions before 2026.3 and 2026.2.4, where the jetbrainsd daemon improperly trusts compromised intermediate certificates. This flaw can lead to a critical security impact including full confidentiality, integrity, and availability compromise.

References

Community reviews

Loading reviews…