In Jupyter Notebook versions 7.0.0 through 7.5.5, JupyterLab versions 4.5.6 and earlier, and the corresponding
Affects jupyter-notebookSource GCVE Database
Not known to be exploited · CVSS 8.4 High · fixed in 7.5.6 : patch jupyter-notebook soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.5.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10jupyter-notebookpkg:deb/ubuntu/jupyter-notebook?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 25.10jupyter-notebookpkg:deb/ubuntu/jupyter-notebook?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSjupyter-notebookpkg:deb/ubuntu/jupyter-notebook?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSjupyter-notebookpkg:deb/ubuntu/jupyter-notebook?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Jupyter Notebook 7.5.6, JupyterLab 4.5.7, and the corresponding help-extension packages 7.5.6 and 4.5.7. Users should upgrade to these versions to remediate the vulnerability. As a workaround, disabling the affected help extensions or setting allowCommandLinker to false in the sanitizer configuration can mitigate the risk until patches are applied.
Description
A stored cross-site scripting (XSS) vulnerability exists in Jupyter Notebook versions 7.0.0 through 7.5.5, JupyterLab versions 4.5.6 and earlier, and related help-extension packages before 7.5.6 and 4.5.7. This flaw allows an attacker to craft malicious notebook content that, when interacted with by a user, can steal authentication tokens. Exploitation enables full session takeover via the REST API, including file access, code execution, and terminal creation. The issue is fixed in Notebook 7.5.6, JupyterLab 4.5.7, and corresponding help-extension updates. Workarounds include disabling affected help extensions or setting allowCommandLinker to false in sanitizer configuration.