In MIT Kerberos 5 (aka krb5) before 1.22.3, there is an integer underflow and resultant out-of-bounds read if an
Affects krb5Source GCVE Database
Not known to be exploited · CVSS 5.9 Medium · fixed in 1.19.2-2ubuntu0.8 : update krb5 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.19.2-2ubuntu0.8, 1.20.1-6ubuntu2.7, 1.22.1-2ubuntu4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the Ubuntu krb5 to 1.19.2-2ubuntu0.8 (package) or 1.20.1-6ubuntu2.7 (package) or 1.22.1-2ubuntu4.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10krb5pkg:deb/ubuntu/krb5?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 20.04 LTSkrb5pkg:deb/ubuntu/krb5@1.17-6ubuntu4.11?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSkrb5pkg:deb/ubuntu/krb5@1.16-2ubuntu0.4+esm5?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in MIT Kerberos 5 version 1.22.3. Users should upgrade to version 1.22.3 or later to remediate this vulnerability. Patch status is confirmed by the version boundary provided. No additional mitigations are indicated.
Description
MIT Kerberos 5 (krb5) versions before 1.22.3 contain an integer underflow vulnerability that leads to an out-of-bounds read when an application calls gss_accept_sec_context() on systems with a NegoEx mechanism registered. This flaw can be triggered by an unauthenticated remote attacker, potentially causing the affected process to terminate unexpectedly during message parsing.