Skip to main content
CVE-2024-7840VulnerabilityPublished Updated

In Progress Telerik Reporting versions prior to 2024 Q3 (2024.3.924), a command injection attack is possible through

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-7840· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 18.2.24.924 soon.

Data as of 30 Oct 2026, 00:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ProgressSoftware)CVSS 3.17.8
Patch
Available – fixed in 18.2.24.924
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade telerik.reporting to 18.2.24.924.

Affected software

ProductAffectedFixed in
NuGettelerik.reportingpkg:nuget/telerik.reportingOther threatsAffected
  • <18.2.24.924
Fixed in
  • 18.2.24.924

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict local access to trusted users and avoid interacting with untrusted hyperlink elements within Telerik Reporting.

Description

A command injection vulnerability exists in Progress Telerik Reporting versions prior to 2024 Q3 (2024.3.924) due to improper neutralization of hyperlink elements. This flaw allows an attacker with local access to execute arbitrary commands, potentially leading to full system compromise. The vulnerability has a high severity score of 7.8 CVSS v3.1. No public exploits or patches are currently confirmed.

References

Community reviews

Loading reviews…