Skip to main content
CVE-2024-57822VulnerabilityPublished Updated

In Raptor RDF Syntax Library through 2.0.16, there is a heap-based buffer over-read when parsing triples with the

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-57822· Medium 4.0

Not known to be exploited · CVSS 4.0 Medium : upgrade to 2.0.17 when convenient.

Data as of 29 Oct 2026, 23:51 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.14.0
Patch
Available – fixed in 2.0.17
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade dajobe/raptor to 2.0.17.

Affected software

ProductAffectedFixed in
GitHubdajobe/raptorpkg:github/dajobe/raptorOther threatsAffected
  • <2.0.17
Fixed in
  • 2.0.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid processing untrusted nquads input with affected versions.

Description

A heap-based buffer over-read vulnerability exists in the Raptor RDF Syntax Library through version 2.0.16. The issue occurs when parsing triples using the nquads parser in the function raptor_ntriples_parse_term_internal(). This flaw can lead to a denial of service due to application crash or instability.

References

Community reviews

Loading reviews…