Skip to main content
CVE-2026-92925VulnerabilityPublished Updated

In Redis community the cluster bus PING/PONG/MEET packet parser validated extension padding and total length but never

Affects redisSource GCVE Database

0
Authoritative record:CVE-2026-92925· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 8.10.0 soon.

Data as of 28 Oct 2026, 05:12 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.10.0
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade redis/redis to 8.10.0.

Affected software

ProductAffectedFixed in
GitHubredis/redispkg:github/redis/redisOther threatsAffected
  • <8.10.0
Fixed in
  • 8.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since Redis Software and Redis Enterprise are not affected, users of those products do not need to take action.

Description

A vulnerability in the Redis community edition cluster bus packet parser allows crafted packets with improperly null-terminated string extensions to trigger out-of-bounds reads. This can lead to loss of confidentiality or remote denial of service. Redis Software and Redis Enterprise are not affected by this issue. The vulnerability has a CVSS score of 7.1, indicating high severity.

References

Community reviews

Loading reviews…