In server mode pgAdmin 4 validates a path a user gives for a file in their storage directory with
Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 9.19 when convenient.
Data as of 30 Oct 2026, 23:27 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 6.5 |
|---|---|---|
| CNA (PostgreSQL) | CVSS 4.0 | 7.3 |
- Patch
- Available – fixed in 9.19
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pgAdmin 4 to 9.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pgadmin.orgpgAdmin 4 | Affected
| Fixed in
|
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pgAdmin 4 version 9.19 that addresses this vulnerability by securely opening files with O_NOFOLLOW and restricting file types. Users should upgrade to version 9.19 or later. No additional mitigations are necessary if the upgrade is applied. If upgrading is not immediately possible, ensure that write access to the storage backend is tightly controlled to prevent attackers from creating malicious links or FIFOs.
Description
pgAdmin 4 in server mode had a vulnerability where symbolic links, hard links, or FIFOs inside a user's storage directory could be used to bypass path validation checks, allowing unauthorized file read, write, or load operations as the operating system user running pgAdmin. This affected file operations related to server.json export/import and files passed to utilities like pg_dump and psql. Exploitation requires write access to the storage backend as a different OS user and a race condition. The issue was fixed in version 9.19 by securely opening files with O_NOFOLLOW and restricting to regular files with a single link.
References
- nvd.nist.gov/vuln/detail/CVE-2026-116250 (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/issues/10647 (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/730d1e783c339ec696a1f77f2eee6f4b52cb6c37 (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/99f5606e2ebc7c94c7acdbab877ce7de54bfc756 (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/c4321b9968342716f34bc5f10de6cac3c0567e68 (opens in a new tab)