Skip to main content
CVE-2025-49812VulnerabilityPublished Updated

In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-49812· High 7.4

Not known to be exploited · CVSS 7.4 High.

Data as of 4 Nov 2026, 17:53 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.4
Affects
Apache HTTP Server up to 2.4.63
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

Users should upgrade Apache HTTP Server to version 2.4.64 or later, which removes support for TLS upgrade and thereby mitigates this vulnerability. No other mitigations are indicated or recommended by the vendor advisory.

Description

An HTTP desynchronisation vulnerability exists in some mod_ssl configurations of Apache HTTP Server versions up to 2.4.63. This issue affects configurations using "SSLEngine optional" to enable TLS upgrades, allowing a man-in-the-middle attacker to hijack HTTP sessions via a TLS upgrade. The vulnerability is resolved by upgrading to Apache HTTP Server version 2.4.64, which removes support for TLS upgrade.

References

Community reviews

Loading reviews…