Skip to main content
VulnerabilityPublished Updated

CVE-2024-10976: PostgreSQL of tables with row security · Incomplete Tracking

Affects postgresqlSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-10976· Medium 4.2

Not known to be exploited · CVSS 4.2 Medium · fixed in 17.1 : update postgresql when convenient.

Data as of 29 Oct 2026, 22:59 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.14.2
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Debiandebian/postgresqlpkg:deb/debian/postgresqlOther threatsAffected
  • <17.1
  • <16.5
  • <15.9
  • <14.14
  • <13.17
  • <12.21
Fixed in
  • 17.1
  • 16.5
  • 15.9
  • 14.14
  • 13.17
  • 12.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory. Applying the official patches fully addresses the issue.

Description

PostgreSQL versions prior to 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 have an incomplete tracking issue with row-level security policies. This flaw allows a reused query to view or modify rows it should not access due to incorrect application of row security policies when queries are planned under one role and executed under others. The vulnerability affects databases using CREATE POLICY for row security and involves scenarios with subqueries, WITH queries, security invoker views, or SQL-language functions referencing tables with row-level security. Exploitation requires tailoring to specific application query plan reuse and role changes.

References

Community reviews

Loading reviews…