Apache Kafka · Incorrect Operator
Affects kafkaSource GCVE Database
Not known to be exploited : upgrade to 4.3.2 or 4.2.2 soon.
Data as of 28 Oct 2026, 22:12 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
- Patch
- Available – fixed in 4.3.2, 4.2.2
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.kafka/kafka to 4.3.2 or 4.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.kafka/kafkapkg:maven/org.apache.kafka/kafkaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Kafka to version 4.2.2, 4.3.2, or 4.4.0 to remediate this vulnerability. Users on unsupported branches (4.1.x and earlier) are also advised to upgrade to 4.2.2 or later. No other mitigations or workarounds are specified.
Description
An incorrect operator vulnerability (CWE-480) exists in the FetchSnapshot RPC handler of Apache Kafka versions from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2. This flaw allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service by terminating the controller process via a crafted FetchSnapshotRequest containing an empty topics array or a topic with no partitions. Fixed versions include 4.2.2, 4.3.2, and 4.4.0.