Skip to main content
CVE-2026-83525VulnerabilityPublished Updated

Apache Kafka · Incorrect Operator

Affects kafkaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-83525· High

Not known to be exploited · fixed in 4.2.2 : patch kafka soon.

Data as of 5 Nov 2026, 12:34 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu Pro 18.04 LTSkafkapkg:deb/ubuntu/kafka?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =2.2.0u2-0ubuntu3.1
  • =2.2.0u2-0ubuntu3.2
  • =2.2.2u1-0ubuntu1+esm2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

References

Community reviews

Loading reviews…