CVE-2025-58438: internetarchive is vulnerable to Directory Traversal through file downloads
Affects internetarchiveSource GCVE Database
Not known to be exploited · CVSS 9.4 Critical : upgrade to 5.11.0 as a priority.
Data as of 30 Oct 2026, 07:30 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 9.4 |
|---|
- Patch
- Available – fixed in 5.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade internetarchive to 5.11.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewinternetarchivepkg:brew/internetarchiveOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.
References
- github.com/jjjake/internetarchive/releases/tag/v5.5.1 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00030.html (opens in a new tab)
- github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58438.json (opens in a new tab)
- github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-58438 (opens in a new tab)
- github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2 (opens in a new tab)