Skip to main content
CVE-2025-58438VulnerabilityPublished Updated

CVE-2025-58438: jjjake internetarchive · Path Traversal

Affects jjjake internetarchiveSource CVE Database V5

0

Not known to be exploited · CVSS 9.4 Critical : upgrade to 5.5.1 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade jjjake internetarchive to 5.5.1.

Affected software

ProductAffectedFixed in
jjjake internetarchiveAffected
  • <5.5.1
Fixed in
  • 5.5.1

AI-suggested

European organizations should immediately upgrade the internetarchive library to version 5.5.1 or later where the vulnerability is patched. They should audit all internal and third-party codebases and pipelines that use this library to identify vulnerable versions. Implement strict input validation and sanitization on any user-supplied filenames or paths before passing them to the File.download() method. Employ application-level sandboxing or containerization to limit the filesystem scope accessible to processes using this library, minimizing potential damage from exploitation. Monitor file integrity of critical system and application files to detect unauthorized changes. Restrict permissions of the user accounts running the affected software to the minimum necessary, avoiding running with administrative or root privileges. Establish network monitoring for unusual file write activities or unexpected outbound connections that could indicate exploitation attempts. Finally, maintain an incident response plan to quickly isolate and remediate affected systems if exploitation is suspected.

Description

internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.

References

Community reviews

Loading reviews…