CVE-2025-58438: Internetarchive Vulnerable to Directory Traversal
Affects internetarchiveSource GCVE Database
Not known to be exploited · CVSS 9.4 Critical : upgrade to 5.5.1 as a priority.
Data as of 27 Oct 2026, 18:29 UTC
- Patch
- Available – fixed in 5.5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade internetarchive to 5.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIinternetarchive | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users must upgrade to internetarchive version 5.5.1 or later to remediate this vulnerability. There is no direct workaround that does not involve upgrading. Users who cannot upgrade should implement a custom download function that sanitizes filenames and validates that the resolved download path remains within the intended directory, but this is not recommended. Upgrading to the patched version is the only safe and supported solution.
Description
A critical directory traversal vulnerability exists in the File.download() method of the internetarchive library versions prior to 5.5.1. This flaw allows malicious filenames containing path traversal sequences to cause files to be written outside the intended directory, potentially overwriting critical system or application files. The vulnerability affects all operating systems but is especially critical on Windows. The issue has been patched in version 5.5.1, and upgrading is the recommended remediation.
References
- github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-58438 (opens in a new tab)
- github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2 (opens in a new tab)
- github.com/jjjake/internetarchive (opens in a new tab)
- github.com/jjjake/internetarchive/releases/tag/v5.5.1 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/internetarchive/PYSEC-2026-357.yaml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00030.html (opens in a new tab)
- pypi.org/project/internetarchive (opens in a new tab)