Skip to main content
CVE-2026-101283VulnerabilityPublished Updated

iperf3 3.20–3.21 (esnet/iperf) has a pre-auth heap buffer overflow in decrypt_rsa_message(): a 256-byte RSA buffer is

Affects iperf3Source GCVE Database

0
Compare
Authoritative record:CVE-2026-101283· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 3.22 : patch iperf3 as a priority.

Data as of 5 Nov 2026, 12:51 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.22
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10iperf3pkg:deb/ubuntu/iperf3?arch=source&distro=stonkingOther threatsAffected
  • =3.20-2
  • =3.20-2.1
  • =3.20-2.1build1
Fixed in–
Ubuntu 26.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=resoluteOther threatsAffected
  • =3.18-2
  • =3.19.1-2
  • =3.20-2
Fixed in–
Ubuntu Pro 24.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 3.14-1 – 3.16-1ubuntu0.1~esm1
6 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/focalOther threatsAffected
  • 3.6-2 – 3.7-3ubuntu0.1~esm2
6 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =3.1.3-1
  • =3.1.3-1ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 16.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/xenialOther threatsAffected
  • =3.0.11-1
  • =3.0.11-1ubuntu0.1~esm1
  • =3.0.11-1ubuntu0.1~esm2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade iperf3 to version 3.22 or later, where this heap buffer overflow vulnerability is fixed. No other mitigations are indicated or effective given the pre-authentication nature of the flaw.

Description

iperf3 versions 3.20 through 3.21 contain a critical pre-authentication heap buffer overflow vulnerability in the decrypt_rsa_message() function. This occurs because a 256-byte RSA buffer is read using BIO_read with an attacker-controlled ciphertext length, allowing an unauthenticated client to overflow the heap by sending an oversized authtoken. The issue is fixed in version 3.22.

References

Community reviews

Loading reviews…