CVE-2025-54351: Iperf3 · In iperf before 3.19.1, net.c has a buffer overflow when --skip-rx-copy is used (for
Affects iperf3Source GCVE Database
Not known to be exploited · CVSS 8.9 High · fixed in 3.19.1 : patch iperf3 soon.
Data as of 5 Nov 2026, 12:51 UTC
- Patch
- Available – fixed in 3.19.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10iperf3pkg:deb/ubuntu/iperf3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10iperf3pkg:deb/ubuntu/iperf3?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSiperf3pkg:deb/ubuntu/iperf3?arch=source&distro=esm-apps/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade iperf3 to version 3.19.1 or later, where this buffer overflow vulnerability is fixed. No other mitigation or workaround is indicated. Applying the official fix is the recommended and effective remediation.
Description
A critical buffer overflow vulnerability exists in iperf3 versions before 3.19.1 in the net.c file when the --skip-rx-copy option is used. This flaw can lead to complete system compromise due to its high severity and impact on confidentiality, integrity, and availability.