IPFire versions prior to 2.29 (Core Update 198) contain a command injection vulnerability that allows an authenticated
Source GCVE Database
Not known to be exploited · CVSS 8.7 High · fixed in 2.29 : patch affected system. IPFire soon.
Data as of 29 Oct 2026, 23:58 UTC
- Affects
- affected system. IPFire prior to 2.29
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
AI-suggested
A fix is available in IPFire version 2.29 (Core Update 198). Users should upgrade to version 2.29 or later to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.
Description
IPFire versions prior to 2.29 (Core Update 198) have a command injection vulnerability that allows an authenticated attacker to execute arbitrary commands as the 'nobody' user via the BE_NAME parameter during blacklist installation. The vulnerability arises because the BE_NAME parameter is unsafely interpolated into a shell command without proper sanitization. This flaw can lead to full compromise of confidentiality, integrity, and availability of the affected system.