Skip to main content
CVE-2025-34304VulnerabilityPublished Updated

IPFire versions prior to 2.29 (Core Update 198) contain a SQL injection vulnerability that allows an authenticated

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34304· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 2.29 : patch affected systems soon.

Data as of 29 Oct 2026, 23:57 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

A fixed version is available starting from IPFire 2.29 (Core Update 198). Users should upgrade to version 2.29 or later to remediate this vulnerability.

Description

IPFire versions prior to 2.29 (Core Update 198) have a SQL injection vulnerability in the OpenVPN connection logs feature. An authenticated attacker can manipulate the CONNECTION_NAME parameter in a POST request to alter the SQL query without proper sanitization. This allows disclosure of sensitive database information. The vulnerability has a CVSS score of 6.5, indicating medium severity.

References

Community reviews

Loading reviews…