IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium · fixed in 2.29 : update affected systems when convenient.
Data as of 29 Oct 2026, 23:58 UTC
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
AI-suggested
Users should upgrade to IPFire version 2.29 (Core Update 198) or later once available, as the vulnerability affects versions prior to 2.29. Until then, restrict authenticated access to trusted users only and avoid editing or viewing Dynamic DNS entries from untrusted environments. Monitor vendor advisories for official fixes.
Description
IPFire versions prior to 2.29 (Core Update 198) have a stored cross-site scripting (XSS) vulnerability. This flaw allows an authenticated attacker to inject arbitrary JavaScript code via the SERVICE, LOGIN, and PASSWORD parameters when creating or editing a Dynamic DNS host. Injected scripts execute in the context of other users who view or edit these entries, potentially leading to session hijacking or other client-side impacts.