Isc dhcp: An attacker can cause named to abort by sending a crafted DNS-over-HTTPS request with a cryptographically
Affects isc-dhcpSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 1:9.20.24-1ubuntu3.1 : patch isc-dhcp soon.
Data as of 3 Nov 2026, 23:36 UTC
- Patch
- Available – fixed in 1:9.20.24-1ubuntu3.1, 1:9.20.24-1ubuntu0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu bind9 to 1:9.20.24-1ubuntu3.1 (package) or 1:9.20.24-1ubuntu0.4 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10bind9pkg:deb/ubuntu/bind9?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSbind9pkg:deb/ubuntu/bind9?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSisc-dhcppkg:deb/ubuntu/isc-dhcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSisc-dhcppkg:deb/ubuntu/isc-dhcp?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSbind9-libspkg:deb/ubuntu/bind9-libs?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSbind9-libspkg:deb/ubuntu/bind9-libs?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected systems. Specifically, upgrading to Ubuntu package versions 1:9.20.24-1ubuntu3.1 or 1:9.20.24-1ubuntu0.4 or later will remediate this vulnerability. No other mitigation or workaround is indicated by the vendor advisory.
Description
A vulnerability in BIND 9 allows a remote attacker to cause the named DNS server process to abort by sending a specially crafted DNS-over-HTTPS request containing a cryptographically invalid SIG(0) record and then closing the connection prematurely. This denial of service issue affects multiple BIND 9 versions and has a high severity rating.