Skip to main content
CVE-2026-76163VulnerabilityPublished Updated

Isc dhcp: If BIND is loaded with a "named.conf" file that contains no global "options" block, an attacker can send a

Affects isc-dhcpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-76163· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 1:9.20.24-1ubuntu3.1 : patch isc-dhcp soon.

Data as of 3 Nov 2026, 23:36 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:9.20.24-1ubuntu3.1, 1:9.20.24-1ubuntu0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu bind9 to 1:9.20.24-1ubuntu3.1 (package) or 1:9.20.24-1ubuntu0.4 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10bind9pkg:deb/ubuntu/bind9?arch=source&distro=stonkingOther threatsAffected
  • <1:9.20.24-1ubuntu3.1
Fixed in
  • 1:9.20.24-1ubuntu3.1
Ubuntu 26.04 LTSbind9pkg:deb/ubuntu/bind9?arch=source&distro=resoluteOther threatsAffected
  • <1:9.20.24-1ubuntu0.4
Fixed in
  • 1:9.20.24-1ubuntu0.4
Ubuntu 26.04 LTSisc-dhcppkg:deb/ubuntu/isc-dhcp?arch=source&distro=resoluteOther threatsAffected
  • =4.4.3-P1-4ubuntu2
Fixed in–
Ubuntu 24.04 LTSisc-dhcppkg:deb/ubuntu/isc-dhcp?arch=source&distro=nobleOther threatsAffected
  • =4.4.3-P1-2ubuntu5
  • =4.4.3-P1-4ubuntu1
  • =4.4.3-P1-4ubuntu2
Fixed in–
Ubuntu 22.04 LTSbind9-libspkg:deb/ubuntu/bind9-libs?arch=source&distro=jammyOther threatsAffected
  • =1:9.11.19+dfsg-2.1ubuntu1
  • =1:9.11.19+dfsg-2.1ubuntu2
  • =1:9.11.19+dfsg-2.1ubuntu3
Fixed in–
Ubuntu 20.04 LTSbind9-libspkg:deb/ubuntu/bind9-libs?arch=source&distro=focalOther threatsAffected
  • =1:9.11.16+dfsg-3~build1
  • =1:9.11.16+dfsg-3~ubuntu1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The fixed versions are 1:9.20.24-1ubuntu3.1 and 1:9.20.24-1ubuntu0.4. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigation actions are indicated by the vendor advisory.

Description

A vulnerability in BIND occurs when it is loaded with a named.conf file lacking a global options block. An attacker can send a TKEY query that triggers an assertion failure, causing the program to exit unexpectedly. This affects BIND 9 versions 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, and 9.20.9-S1 through 9.20.27-S1. The issue results in a denial of service due to service interruption.

References

Community reviews

Loading reviews…