Skip to main content
CVE-2026-102802VulnerabilityPublished

Joomla Extension - regularlabs.com - PHP code injection vector in Sourcerer extension < 17.0.1 when used with Articles

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-102802· High 8.9

Not known to be exploited · CVSS 8.9 High.

Data as of 2 Nov 2026, 17:02 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Joomla)CVSS 4.08.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Sourcerer Free extension for Joomlaplg_system_sourcererAffected
  • =13.0.0-17.0.0
Fixed in–
Sourcerer Pro extension for Joomlaplg_system_sourcererAffected
  • =3.0.0-17.0.0
Fixed in–
Articles Anywhere extension for Joomlaplg_system_articlesanywhereAffected
  • =1.4.5-20.1.0
Fixed in–

AI-suggested

A fix is available by upgrading the Sourcerer extension to version 17.0.1 or later and the Articles Anywhere extension to version 20.1.1 or later. Users should apply these updates to ensure the PHP code execution restrictions are properly enforced. There is no indication that the vulnerability is mitigated by configuration alone, so patching is the recommended action.

Description

A PHP code injection vulnerability exists in the Joomla Sourcerer extension versions prior to 17.0.1 when used in combination with the Articles Anywhere extension versions prior to 20.1.1. The issue arises because Articles Anywhere can insert one article into another, and when processing occurs in a certain order with Force Content Triggers disabled, the included article's Sourcerer code may be executed with the trust level of the enclosing article rather than its own. This creates a mismatch in authority validation for executing PHP code within articles.

References

Community reviews

Loading reviews…