Skip to main content
VulnerabilityPublished Updated

CVE-2024-47545: GHSL-2024-242 · GStreamer has an integer underflow in FOURCC_strf parsing leading to OOB-read

Affects jreSource GCVE Database

0

Not known to be exploited : upgrade to 8.0.451 or 1.8.0 soon.

Data as of 26 Oct 2026, 12:29 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.451, 1.8.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jre to 8.0.451 or 1.8.0.

Affected software

ProductAffectedFixed in
Bitnamijrepkg:bitnami/jreOther threatsAffected
  • <1.8.0
  • >=1.9.0 <8.0.451
Fixed in
  • 1.8.0
  • 8.0.451

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in GStreamer version 1.24.10. Users should upgrade to version 1.24.10 or later to remediate this issue.

Description

GStreamer, a media-handling library, contains an integer underflow vulnerability in the qtdemux_parse_trak function within qtdemux.c. The flaw occurs during FOURCC strf parsing, where a subtraction operation can cause a negative integer underflow if the size is less than 40. This leads to an out-of-bounds read when memcpy is called with an incorrect size. The vulnerability is fixed in version 1.24.10.

References

Community reviews

Loading reviews…